aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..7f297bf
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,11 @@
1{ pkgs ? import <nixpkgs> {} }:
2
3pkgs.mkShell {
4 name = "rust-env";
5 nativeBuildInputs = with pkgs; [
6 rustc cargo
7 ];
8 buildInputs = with pkgs; [ xorg.libxcb python3 ];
9
10 RUST_BACKTRACE = 1;
11}