aboutsummaryrefslogtreecommitdiff
path: root/programs/tmux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'programs/tmux.nix')
-rw-r--r--programs/tmux.nix23
1 files changed, 12 insertions, 11 deletions
diff --git a/programs/tmux.nix b/programs/tmux.nix
index 5f58108..8679222 100644
--- a/programs/tmux.nix
+++ b/programs/tmux.nix
@@ -10,10 +10,10 @@
10 tmuxPlugins.fingers 10 tmuxPlugins.fingers
11 ]; 11 ];
12 extraConfig = '' 12 extraConfig = ''
13 set -g prefix C-a 13 set -g prefix C-t
14 setw -g mode-keys vi 14 setw -g mode-keys vi
15 unbind-key C-b 15 unbind-key C-b
16 bind-key C-a send-prefix 16 bind-key C-t send-prefix
17 17
18 bind r source-file ~/.config/tmux/tmux.conf 18 bind r source-file ~/.config/tmux/tmux.conf
19 19
@@ -27,19 +27,19 @@
27 27
28 # pane binds 28 # pane binds
29 bind-key h select-pane -L 29 bind-key h select-pane -L
30 bind-key j select-pane -D 30 bind-key n select-pane -D
31 bind-key k select-pane -U 31 bind-key e select-pane -U
32 bind-key l select-pane -R 32 bind-key i select-pane -R
33 bind-key -r H resize-pane -L 5 33 bind-key -r H resize-pane -L 5
34 bind-key -r J resize-pane -D 5 34 bind-key -r N resize-pane -D 5
35 bind-key -r K resize-pane -U 5 35 bind-key -r E resize-pane -U 5
36 bind-key -r L resize-pane -R 5 36 bind-key -r I resize-pane -R 5
37 37
38 # window binds 38 # window binds
39 bind -n M-h previous-window 39 bind -n M-h previous-window
40 bind -n M-l next-window 40 bind -n M-i next-window
41 bind-key "|" split-window -h -c "#{pane_current_path}" 41 bind-key "{" split-window -h -c "#{pane_current_path}"
42 bind-key "-" split-window -v -c "#{pane_current_path}" 42 bind-key "}" split-window -v -c "#{pane_current_path}"
43 bind-key s choose-session 43 bind-key s choose-session
44 bind-key c new-window -c "#{pane_current_path}" 44 bind-key c new-window -c "#{pane_current_path}"
45 bind-key ) swap-window -t +1 45 bind-key ) swap-window -t +1
@@ -84,6 +84,7 @@
84 # status left 84 # status left
85 set -g status-left "#[fg=colour7]#(${pkgs.prompt}/bin/prompt cwd '#{pane_current_path}') " 85 set -g status-left "#[fg=colour7]#(${pkgs.prompt}/bin/prompt cwd '#{pane_current_path}') "
86 set -ag status-left "#[fg=colour7]#(${pkgs.prompt}/bin/prompt vcs '#{pane_current_path}')" 86 set -ag status-left "#[fg=colour7]#(${pkgs.prompt}/bin/prompt vcs '#{pane_current_path}')"
87 set status-left-length 50
87 ''; 88 '';
88 }; 89 };
89} 90}