aboutsummaryrefslogtreecommitdiff
path: root/services/sxhkd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'services/sxhkd.nix')
-rw-r--r--services/sxhkd.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/services/sxhkd.nix b/services/sxhkd.nix
index 8658875..debe1b5 100644
--- a/services/sxhkd.nix
+++ b/services/sxhkd.nix
@@ -4,6 +4,9 @@
4, ... 4, ...
5}: 5}:
6 6
7let
8 jumpTo = app: "${pkgs.xdotool}/bin/xdotool search \"${app}\" windowactivate";
9in
7{ 10{
8 services.sxhkd = { 11 services.sxhkd = {
9 enable = true; 12 enable = true;
@@ -11,7 +14,15 @@
11 "XF86Audio{Lower,Raise}Volume" = "${pkgs.alsaUtils}/bin/amixer sset Master 2%{-,+}"; 14 "XF86Audio{Lower,Raise}Volume" = "${pkgs.alsaUtils}/bin/amixer sset Master 2%{-,+}";
12 "XF86AudioMute" = "${pkgs.alsaUtils}/bin/amixer sset Master toggle"; 15 "XF86AudioMute" = "${pkgs.alsaUtils}/bin/amixer sset Master toggle";
13 "XF86MonBrightness{Down,Up}" = "${pkgs.light}/bin/light -{U,A} 5"; 16 "XF86MonBrightness{Down,Up}" = "${pkgs.light}/bin/light -{U,A} 5";
14 "super + Escape" = "pkill -USR1 -x sxhkd"; 17
18 # jump to firefox
19 "super + alt + shift + ctrl + f" = jumpTo "Mozilla Firefox";
20
21 # jump to st
22 "super + alt + shift + ctrl + s" = jumpTo "st";
23
24 # jump to zathura
25 "super + alt + shift + ctrl + z" = jumpTo "zathura";
15 }; 26 };
16 }; 27 };
17} 28}