aboutsummaryrefslogtreecommitdiff
path: root/crates/ide/Cargo.toml
diff options
context:
space:
mode:
authorPavan Kumar Sunkara <[email protected]>2020-08-24 09:25:19 +0100
committerPavan Kumar Sunkara <[email protected]>2020-08-24 10:10:41 +0100
commita8fa5cd42e3cfa131121a46b289ee919e495316e (patch)
treed72e341c36d588cc44832ed43f769ef345274c54 /crates/ide/Cargo.toml
parente65d48d1fb3d4d91d9dc1148a7a836ff5c9a3c87 (diff)
Add version to deps in cargo.toml
Diffstat (limited to 'crates/ide/Cargo.toml')
-rw-r--r--crates/ide/Cargo.toml22
1 files changed, 11 insertions, 11 deletions
diff --git a/crates/ide/Cargo.toml b/crates/ide/Cargo.toml
index 700944430..688401098 100644
--- a/crates/ide/Cargo.toml
+++ b/crates/ide/Cargo.toml
@@ -16,20 +16,20 @@ log = "0.4.8"
16rustc-hash = "1.1.0" 16rustc-hash = "1.1.0"
17oorandom = "11.1.2" 17oorandom = "11.1.2"
18 18
19stdx = { path = "../stdx" } 19stdx = { path = "../stdx", version = "0.0.0" }
20syntax = { path = "../syntax" } 20syntax = { path = "../syntax", version = "0.0.0" }
21text_edit = { path = "../text_edit" } 21text_edit = { path = "../text_edit", version = "0.0.0" }
22base_db = { path = "../base_db" } 22base_db = { path = "../base_db", version = "0.0.0" }
23ide_db = { path = "../ide_db" } 23ide_db = { path = "../ide_db", version = "0.0.0" }
24cfg = { path = "../cfg" } 24cfg = { path = "../cfg", version = "0.0.0" }
25profile = { path = "../profile" } 25profile = { path = "../profile", version = "0.0.0" }
26test_utils = { path = "../test_utils" } 26test_utils = { path = "../test_utils", version = "0.0.0" }
27assists = { path = "../assists" } 27assists = { path = "../assists", version = "0.0.0" }
28ssr = { path = "../ssr" } 28ssr = { path = "../ssr", version = "0.0.0" }
29 29
30# ide should depend only on the top-level `hir` package. if you need 30# ide should depend only on the top-level `hir` package. if you need
31# something from some `hir_xxx` subpackage, reexport the API via `hir`. 31# something from some `hir_xxx` subpackage, reexport the API via `hir`.
32hir = { path = "../hir" } 32hir = { path = "../hir", version = "0.0.0" }
33 33
34[dev-dependencies] 34[dev-dependencies]
35expect-test = "0.1" 35expect-test = "0.1"