aboutsummaryrefslogtreecommitdiff
path: root/crates/syntax/fuzz/Cargo.toml
diff options
context:
space:
mode:
authorIgor Aleksanov <[email protected]>2020-08-14 05:34:07 +0100
committerIgor Aleksanov <[email protected]>2020-08-14 05:34:07 +0100
commitc26c911ec1e6c2ad1dcb7d155a6a1d528839ad1a (patch)
tree7cff36c38234be0afb65273146d8247083a5cfeb /crates/syntax/fuzz/Cargo.toml
parent3c018bf84de5c693b5ee1c6bec0fed3b201c2060 (diff)
parentf1f73649a686dc6e6449afc35e0fa6fed00e225d (diff)
Merge branch 'master' into add-disable-diagnostics
Diffstat (limited to 'crates/syntax/fuzz/Cargo.toml')
-rw-r--r--crates/syntax/fuzz/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/crates/syntax/fuzz/Cargo.toml b/crates/syntax/fuzz/Cargo.toml
new file mode 100644
index 000000000..32c40d1b9
--- /dev/null
+++ b/crates/syntax/fuzz/Cargo.toml
@@ -0,0 +1,27 @@
1
2[package]
3name = "syntax-fuzz"
4version = "0.0.1"
5authors = ["rust-analyzer developers"]
6publish = false
7edition = "2018"
8
9[package.metadata]
10cargo-fuzz = true
11
12[dependencies]
13syntax = { path = ".." }
14text_edit = { path = "../../text_edit" }
15libfuzzer-sys = { git = "https://github.com/rust-fuzz/libfuzzer-sys.git" }
16
17# Prevent this from interfering with workspaces
18[workspace]
19members = ["."]
20
21[[bin]]
22name = "parser"
23path = "fuzz_targets/parser.rs"
24
25[[bin]]
26name = "reparse"
27path = "fuzz_targets/reparse.rs"