aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 11 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d34251fc0..498cf7d62 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,7 +1,12 @@
1[workspace] 1[workspace]
2resolver = "2"
2members = ["xtask/", "lib/*", "crates/*"] 3members = ["xtask/", "lib/*", "crates/*"]
3 4
4[profile.dev] 5[profile.dev]
6# We do want incremental builds, but they are broken at the moment :(
7# https://github.com/rust-lang/rust/issues/85003#issuecomment-833796289
8incremental = false
9
5# Disabling debug info speeds up builds a bunch, 10# Disabling debug info speeds up builds a bunch,
6# and we don't rely on it for debugging that much. 11# and we don't rely on it for debugging that much.
7debug = 0 12debug = 0
@@ -16,9 +21,14 @@ text-size.opt-level = 3
16miniz_oxide.opt-level = 3 21miniz_oxide.opt-level = 3
17 22
18[profile.release] 23[profile.release]
19incremental = true 24# We do want incremental release builds, but they are broken at the moment :(
25# https://github.com/rust-lang/rust/issues/85003#issuecomment-833796289
26incremental = false
20debug = 0 # Set this to 1 or 2 to get more useful backtraces in debugger. 27debug = 0 # Set this to 1 or 2 to get more useful backtraces in debugger.
21 28
29[profile.test]
30incremental = false
31
22[patch.'crates-io'] 32[patch.'crates-io']
23# rowan = { path = "../rowan" } 33# rowan = { path = "../rowan" }
24 34