summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..19f063e
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,19 @@
1{
2 description = "Project presentation for Finite Automata and Formal Languages";
3
4 outputs = { self, nixpkgs }:
5 let
6 pkgs = import nixpkgs { system = "x86_64-linux"; };
7 in
8 with pkgs;
9 {
10 defaultPackage.x86_64-linux = stdenv.mkDerivation {
11 name = "fafl";
12 src = ./.;
13 buildInputs = [
14 texlive.combined.scheme-full
15 gnumake
16 ];
17 };
18 };
19}