aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 7 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9cf3639..fc18bb9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
1[package] 1[package]
2name = "dijo" 2name = "dijo"
3version = "0.1.4" 3version = "0.2.3"
4authors = ["Akshay <[email protected]>"] 4authors = ["Akshay <[email protected]>"]
5edition = "2018" 5edition = "2018"
6description = "Scriptable, curses-based, digital habit tracker" 6description = "Scriptable, curses-based, digital habit tracker"
@@ -19,11 +19,11 @@ typetag = "0.1.4"
19directories = "3.0.1" 19directories = "3.0.1"
20clap = "2.33" 20clap = "2.33"
21notify = "4.0" 21notify = "4.0"
22toml = "0.5.6"
22 23
23[dependencies.cursive] 24[dependencies.cursive]
24version = "0.15" 25version = "0.15"
25default-features = false 26default-features = false
26features = ["termion-backend"]
27 27
28[dependencies.chrono] 28[dependencies.chrono]
29version = "0.4" 29version = "0.4"
@@ -32,3 +32,8 @@ features = ["serde"]
32[dependencies.serde] 32[dependencies.serde]
33version = "1.0.103" 33version = "1.0.103"
34features = ["derive"] 34features = ["derive"]
35
36[features]
37default = ["termion-backend"]
38termion-backend = ["cursive/termion-backend"]
39crossterm-backend = ["cursive/crossterm-backend"]