aboutsummaryrefslogtreecommitdiff
path: root/x/rofi.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2021-09-26 16:56:36 +0100
committerAkshay <[email protected]>2021-09-26 16:56:36 +0100
commit5cdb4e421a809de51c3ebe8404e50d732721238b (patch)
tree73b71617c41b3e13edbf26035e821bb884d30441 /x/rofi.nix
init
Diffstat (limited to 'x/rofi.nix')
-rw-r--r--x/rofi.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/x/rofi.nix b/x/rofi.nix
new file mode 100644
index 0000000..ff80b05
--- /dev/null
+++ b/x/rofi.nix
@@ -0,0 +1,30 @@
1{ config
2, pkgs
3, theme
4, ...
5}:
6
7with theme;
8{
9 xresources.properties = {
10 "rofi.color-enabled" = true;
11
12 "rofi.color-window" = "${base00}, ${base00}, ${base00}, ${base00}, ${base03}";
13 "rofi.color-normal" = "${base00}, ${base03}, ${base00}, ${base00}, ${base07}";
14 "rofi.color-active" = "${base03}, ${base0E}, ${base00}, ${base0B}, ${base00}";
15 "rofi.color-urgent" = "${base00}, ${base03}, ${base00}, ${base00}, ${base03}";
16
17 "rofi.fake-transparency" = true;
18 "rofi.font" = "Input 13";
19 "rofi.columns" = 1;
20 "rofi.separator-style" = "none";
21 "rofi.hide-scrollbar" = true;
22 "rofi.location" = 1;
23 "rofi.yoffset" = 20;
24 "rofi.xoffset" = 20;
25 "rofi.padding" = 32;
26 "rofi.fullscreen" = false;
27 "rofi.width" = 300;
28 "rofi.lines" = 6;
29 };
30}