aboutsummaryrefslogtreecommitdiff
path: root/x/rxvt.nix
diff options
context:
space:
mode:
authorAkshay <[email protected]>2021-09-26 16:56:36 +0100
committerAkshay <[email protected]>2021-09-26 16:56:36 +0100
commit5cdb4e421a809de51c3ebe8404e50d732721238b (patch)
tree73b71617c41b3e13edbf26035e821bb884d30441 /x/rxvt.nix
init
Diffstat (limited to 'x/rxvt.nix')
-rw-r--r--x/rxvt.nix58
1 files changed, 58 insertions, 0 deletions
diff --git a/x/rxvt.nix b/x/rxvt.nix
new file mode 100644
index 0000000..3498bd0
--- /dev/null
+++ b/x/rxvt.nix
@@ -0,0 +1,58 @@
1{ config
2, pkgs
3, theme
4, ...
5}:
6
7with theme;
8{
9 xresources.properties = {
10 "*foreground" = base05;
11 "*background" = base00;
12 "*cursorColor" = base05;
13
14 "*color0" = base00;
15 "*color1" = base08;
16 "*color2" = base0B;
17 "*color3" = base0A;
18 "*color4" = base0D;
19 "*color5" = base0E;
20 "*color6" = base0C;
21 "*color7" = base05;
22
23 "*color8" = base03;
24 "*color9" = base09;
25 "*color10" = base01;
26 "*color11" = base02;
27 "*color12" = base04;
28 "*color13" = base06;
29 "*color14" = base0F;
30 "*color15" = base07;
31
32 "*.cursorBlink" = "on";
33 "URxvt.font" = "xft:Nerd Input:size=11:style=Medium";
34 "URxvt.italicFont" = "xft:Nerd Input:size=11:style=Medium";
35 "URxvt.boldFont" = "xft:Nerd Input:size=11:style=Medium";
36 "*font" = "Nerd Input:size=11:style=Regular";
37 "*italicFont" = "Nerd Input:size=11:style=Italic";
38 "*boldFont" = "Nerd Input:size=11:style=Bold";
39
40 "URxvt.lineSpace" = 0;
41 "URxvt.letterSpace" = 0;
42 "URxvt.scrollBar" = false;
43 "URxvt.internalBorder" = 25;
44 "URxvt.cursorUnderline" = false;
45 "URxvt.geometry" = "70x35";
46 "URxvt.thickness" = 5;
47 "URxvt.titleBar" = false;
48 "URxvt.intensityStyles" = false;
49
50
51 "*.perl-ext-common" = "default,matcher,font-size";
52 "URxvt.keysym.C-Up" = "perl:font-size:increase";
53 "URxvt.keysym.C-Down" = "perl:font-size:decrease";
54 "URxvt.keysym.C-equal" = "perl:font-size:reset";
55 "*.url-launcher" = "firefox";
56 "*.matcher.button" = 1;
57 };
58}