diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 38 |
1 files changed, 30 insertions, 8 deletions
@@ -2,19 +2,19 @@ | |||
2 | description = "nerdypepper's nixos config"; | 2 | description = "nerdypepper's nixos config"; |
3 | 3 | ||
4 | inputs = { | 4 | inputs = { |
5 | nixpkgs.url = "github:NixOS/nixpkgs/nixos-22.05"; | 5 | nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable"; |
6 | 6 | ||
7 | nixos-hardware.url = "github:nixos/nixos-hardware"; | 7 | nixos-hardware.url = "github:nixos/nixos-hardware"; |
8 | 8 | ||
9 | home-manager = { | 9 | home-manager = { |
10 | url = "github:nix-community/home-manager/release-22.05"; | 10 | url = "github:nix-community/home-manager/release-22.11"; |
11 | inputs.nixpkgs.follows = "nixpkgs"; | 11 | inputs.nixpkgs.follows = "nixpkgs"; |
12 | }; | 12 | }; |
13 | 13 | ||
14 | statix = { | 14 | # statix = { |
15 | url = "git+https://git.peppe.rs/languages/statix"; | 15 | # url = "git+https://git.peppe.rs/languages/statix"; |
16 | inputs.nixpkgs.follows = "nixpkgs"; | 16 | # inputs.nixpkgs.follows = "nixpkgs"; |
17 | }; | 17 | # }; |
18 | 18 | ||
19 | prompt = { | 19 | prompt = { |
20 | url = "git+https://git.peppe.rs/cli/prompt"; | 20 | url = "git+https://git.peppe.rs/cli/prompt"; |
@@ -28,13 +28,13 @@ | |||
28 | , nixpkgs | 28 | , nixpkgs |
29 | , nixos-hardware | 29 | , nixos-hardware |
30 | , home-manager | 30 | , home-manager |
31 | , statix | 31 | # , statix |
32 | , prompt | 32 | , prompt |
33 | , ... | 33 | , ... |
34 | } @ inputs: { | 34 | } @ inputs: { |
35 | 35 | ||
36 | overlays = { | 36 | overlays = { |
37 | statix = statix.overlay; | 37 | # statix = statix.overlay; |
38 | prompt = prompt.overlay; | 38 | prompt = prompt.overlay; |
39 | }; | 39 | }; |
40 | 40 | ||
@@ -60,6 +60,28 @@ | |||
60 | } | 60 | } |
61 | ]; | 61 | ]; |
62 | }; | 62 | }; |
63 | |||
64 | myrtle = nixpkgs.lib.nixosSystem { | ||
65 | system = "x86_64-linux"; | ||
66 | modules = [ | ||
67 | ({ config = { nix.registry.nixpkgs.flake = nixpkgs; }; }) | ||
68 | { | ||
69 | imports = [ ./hosts/myrtle/configuration.nix ]; | ||
70 | _module.args.self = self; | ||
71 | } | ||
72 | home-manager.nixosModules.home-manager | ||
73 | { | ||
74 | home-manager.useGlobalPkgs = true; | ||
75 | home-manager.useUserPackages = true; | ||
76 | home-manager.users.np = { | ||
77 | imports = [ ./home.nix ]; | ||
78 | _module.args.self = self; | ||
79 | _module.args.inputs = inputs; | ||
80 | _module.args.theme = import ./theme; | ||
81 | }; | ||
82 | } | ||
83 | ]; | ||
84 | }; | ||
63 | }; | 85 | }; |
64 | }; | 86 | }; |
65 | 87 | ||