aboutsummaryrefslogtreecommitdiff
path: root/hosts/olive/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/olive/configuration.nix')
-rw-r--r--hosts/olive/configuration.nix147
1 files changed, 0 insertions, 147 deletions
diff --git a/hosts/olive/configuration.nix b/hosts/olive/configuration.nix
deleted file mode 100644
index 3d5d47f..0000000
--- a/hosts/olive/configuration.nix
+++ /dev/null
@@ -1,147 +0,0 @@
1{ config, pkgs, lib, self, ... }:
2
3{
4 imports =
5 [
6 ./hardware-configuration.nix
7 ../../services/suspend.nix
8 ];
9
10 boot.loader.systemd-boot.enable = true;
11 boot.loader.efi.canTouchEfiVariables = true;
12 boot.kernel.sysctl."net.ipv4.ip_forward" = 1;
13
14 networking = {
15 hostName = "olive";
16 wireless = {
17 iwd.enable = true;
18 interfaces = [ "wlan0" ];
19 environmentFile = "/home/np/.wireless.env";
20 networks = {
21 Sanic.psk = "@PSK_SANI@";
22 Gopalan.psk = "@PSK_GOPA@";
23 Srividhya.psk = "@PSK_SRIV@";
24 sage.psk = "@PSK_SAGE@";
25 };
26 extraConfig = ''
27 ctrl_interface=/run/wpa_supplicant
28 ctrl_interface_group=wheel
29 '';
30 };
31 useDHCP = false;
32 interfaces.wlan0.useDHCP = true;
33 };
34
35 networking.nameservers = [ "1.1.1.1" "1.0.0.1" ];
36
37 i18n.defaultLocale = "en_US.UTF-8";
38 time.timeZone = "Asia/Kolkata";
39
40 nixpkgs.config = {
41 "2bwm".patches = [
42 ../../patches/2bwm/nerd-patch.diff
43 ];
44
45 st = {
46 conf = builtins.readFile ../../programs/st/config.h;
47 extraLibs = with pkgs; [ harfbuzz ];
48 patches = [
49 ../../patches/st/xres.diff
50 ../../patches/st/bright.diff
51 ../../patches/st/ligatures.diff
52 ];
53 };
54
55 # for zoom-us
56 allowUnfree = true;
57 };
58
59 nixpkgs.overlays = with self.overlays; [
60 statix
61 prompt
62 ];
63
64 environment.systemPackages = with pkgs; [
65 _2bwm
66 man-pages
67 man-pages-posix
68 (lib.hiPrio pkgs.bashInteractive_5)
69 ];
70
71 documentation = {
72 dev.enable = true;
73 man.generateCaches = true;
74 };
75
76 users.motd = with config; ''
77 Host ${networking.hostName}
78 OS NixOS ${system.nixos.release} (${system.nixos.codeName})
79 Version ${system.nixos.version}
80 Kernel ${boot.kernelPackages.kernel.version}
81 '';
82
83 programs = {
84 light.enable = true;
85 adb.enable = true;
86 };
87
88 sound.enable = true;
89
90 hardware = {
91 pulseaudio = {
92 enable = true;
93 package = pkgs.pulseaudioFull;
94 extraConfig = "load-module module-bluetooth-policy auto_switch=2";
95 };
96 bluetooth = {
97 enable = true;
98 powerOnBoot = true;
99 };
100 };
101
102 # Enable the X11 windowing system.
103 services.xserver = {
104 enable = true;
105 layout = "us";
106 displayManager.startx.enable = true;
107 libinput.enable = true;
108 };
109
110 services.batteryNotifier = {
111 enable = true;
112 notifyCapacity = 20;
113 suspendCapacity = 10;
114 };
115
116 services.udev.extraRules = builtins.readFile ./qmk.rules;
117
118 users.users.np = {
119 isNormalUser = true;
120 home = "/home/np";
121 extraGroups = [ "wheel" "users" "tty" "audio" "video" "input" "adbusers" "docker" ];
122 };
123
124 nix = {
125 package = pkgs.nixUnstable;
126 extraOptions = ''
127 experimental-features = nix-command flakes
128 warn-dirty = false
129 keep-outputs = false
130 keep-derivations = false
131 '';
132 settings = {
133 trusted-users = [
134 "root"
135 "np"
136 ];
137 };
138 };
139
140 # This value determines the NixOS release from which the default
141 # settings for stateful data, like file locations and database versions
142 # on your system were taken. It‘s perfectly fine and recommended to leave
143 # this value at the release version of the first install of this system.
144 # Before changing this value read the documentation for this option
145 # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
146 system.stateVersion = "20.03"; # Did you read the comment?
147}