aboutsummaryrefslogtreecommitdiff
path: root/hosts/olive/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/olive/hardware-configuration.nix')
-rw-r--r--hosts/olive/hardware-configuration.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/hosts/olive/hardware-configuration.nix b/hosts/olive/hardware-configuration.nix
new file mode 100644
index 0000000..fc9ccb8
--- /dev/null
+++ b/hosts/olive/hardware-configuration.nix
@@ -0,0 +1,36 @@
1# Do not modify this file! It was generated by ‘nixos-generate-config’
2# and may be overwritten by future invocations. Please make changes
3# to /etc/nixos/configuration.nix instead.
4{ config, lib, pkgs, modulesPath, ... }:
5
6{
7 imports = [
8 "${modulesPath}/installer/scan/not-detected.nix"
9 ];
10
11 boot.initrd.availableKernelModules = [
12 "xhci_pci"
13 "ahci"
14 "nvme"
15 "usb_storage"
16 "sd_mod"
17 ];
18 boot.initrd.kernelModules = [ ];
19 boot.kernelModules = [ "kvm-intel" ];
20 boot.extraModulePackages = [ ];
21
22 fileSystems."/" = {
23 device = "/dev/disk/by-uuid/27a7c854-e674-411f-9d79-37084922c91d";
24 fsType = "ext4";
25 };
26
27 fileSystems."/boot" = {
28 device = "/dev/disk/by-uuid/882C-54D5";
29 fsType = "vfat";
30 };
31
32 swapDevices = [ ];
33
34 nix.maxJobs = lib.mkDefault 8;
35 powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
36}