diff options
Diffstat (limited to 'programs/fuzzel.nix')
-rw-r--r-- | programs/fuzzel.nix | 42 |
1 files changed, 42 insertions, 0 deletions
diff --git a/programs/fuzzel.nix b/programs/fuzzel.nix new file mode 100644 index 0000000..8a87911 --- /dev/null +++ b/programs/fuzzel.nix | |||
@@ -0,0 +1,42 @@ | |||
1 | { config | ||
2 | , pkgs | ||
3 | , theme | ||
4 | , font | ||
5 | , ... | ||
6 | }: | ||
7 | |||
8 | with theme; | ||
9 | let | ||
10 | fuzzelColor = themeColor: (builtins.replaceStrings [ "#" ] [ "" ] themeColor) + "ff"; | ||
11 | in | ||
12 | { | ||
13 | programs.fuzzel = { | ||
14 | enable = true; | ||
15 | settings = { | ||
16 | main = { | ||
17 | font = "${font.name}:size=12"; | ||
18 | prompt = ""; | ||
19 | anchor = "top-left"; | ||
20 | icons-enabled = "no"; | ||
21 | fields = "filename,exec,name,generic"; | ||
22 | horizontal-pad = 12; | ||
23 | vertical-pad = 12; | ||
24 | }; | ||
25 | colors = { | ||
26 | background = "${fuzzelColor theme.base00}"; | ||
27 | text = "${fuzzelColor theme.base02}"; | ||
28 | match = "${fuzzelColor theme.base0C}"; | ||
29 | selection = "${fuzzelColor theme.base00}"; | ||
30 | selection-text = "${fuzzelColor theme.base05}"; | ||
31 | selection-match = "${fuzzelColor theme.base0C}"; | ||
32 | border = "${fuzzelColor theme.base02}"; | ||
33 | }; | ||
34 | border = { | ||
35 | width = 2; | ||
36 | radius = 0; | ||
37 | }; | ||
38 | }; | ||
39 | }; | ||
40 | } | ||
41 | |||
42 | |||