diff options
Diffstat (limited to 'programs/git.nix')
-rw-r--r-- | programs/git.nix | 55 |
1 files changed, 28 insertions, 27 deletions
diff --git a/programs/git.nix b/programs/git.nix index 1a2bc72..dc842ce 100644 --- a/programs/git.nix +++ b/programs/git.nix | |||
@@ -9,35 +9,9 @@ with theme; | |||
9 | programs.git = { | 9 | programs.git = { |
10 | enable = true; | 10 | enable = true; |
11 | ignores = [ ".envrc" ]; | 11 | ignores = [ ".envrc" ]; |
12 | delta.enable = true; | ||
12 | userEmail = "[email protected]"; | 13 | userEmail = "[email protected]"; |
13 | userName = "Akshay"; | 14 | userName = "Akshay"; |
14 | delta = { | ||
15 | enable = true; | ||
16 | options = { | ||
17 | features = "decorations labels"; | ||
18 | syntax-theme = "none"; | ||
19 | zero-style = "8"; | ||
20 | navigate = "true"; | ||
21 | keep-plus-minus-markers = "true"; | ||
22 | decorations = { | ||
23 | file-decoration-style = "none"; | ||
24 | whitespace-error-style = "22 reverse"; | ||
25 | minus-style = "${base08}"; | ||
26 | minus-emph-style = "${base08} bold"; | ||
27 | plus-style = "${base0B}"; | ||
28 | plus-emph-style = "${base0B} bold"; | ||
29 | file-style = "7 italic"; | ||
30 | hunk-header-style = "7"; | ||
31 | hunk-header-decoration-style = "8 ul"; | ||
32 | }; | ||
33 | labels = { | ||
34 | file-modified-label = " MODIFIED "; | ||
35 | file-removed-label = " REMOVED "; | ||
36 | file-added-label = " ADDED "; | ||
37 | file-renamed-label = " RENAMED "; | ||
38 | }; | ||
39 | }; | ||
40 | }; | ||
41 | extraConfig = { | 15 | extraConfig = { |
42 | commit.verbose = true; | 16 | commit.verbose = true; |
43 | core = { | 17 | core = { |
@@ -46,3 +20,30 @@ with theme; | |||
46 | }; | 20 | }; |
47 | }; | 21 | }; |
48 | } | 22 | } |
23 | # delta = { | ||
24 | # enable = true; | ||
25 | # options = { | ||
26 | # features = "decorations labels"; | ||
27 | # syntax-theme = "none"; | ||
28 | # zero-style = "8"; | ||
29 | # navigate = "true"; | ||
30 | # keep-plus-minus-markers = "true"; | ||
31 | # decorations = { | ||
32 | # file-decoration-style = "none"; | ||
33 | # whitespace-error-style = "22 reverse"; | ||
34 | # minus-style = "${base08}"; | ||
35 | # minus-emph-style = "${base08} bold"; | ||
36 | # plus-style = "${base0B}"; | ||
37 | # plus-emph-style = "${base0B} bold"; | ||
38 | # file-style = "7 italic"; | ||
39 | # hunk-header-style = "7"; | ||
40 | # hunk-header-decoration-style = "8 ul"; | ||
41 | # }; | ||
42 | # labels = { | ||
43 | # file-modified-label = " MODIFIED "; | ||
44 | # file-removed-label = " REMOVED "; | ||
45 | # file-added-label = " ADDED "; | ||
46 | # file-renamed-label = " RENAMED "; | ||
47 | # }; | ||
48 | # }; | ||
49 | # }; | ||