aboutsummaryrefslogtreecommitdiff
path: root/programs/neovim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'programs/neovim.nix')
-rw-r--r--programs/neovim.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/programs/neovim.nix b/programs/neovim.nix
new file mode 100644
index 0000000..18baeac
--- /dev/null
+++ b/programs/neovim.nix
@@ -0,0 +1,45 @@
1{ config
2, pkgs
3, ...
4}:
5
6{
7 programs.neovim = {
8 enable = true;
9 extraConfig = builtins.readFile ./init.vim;
10 withNodeJs = false;
11 vimAlias = true;
12 withPython3 = true;
13 extraPackages = with pkgs; [
14 gcc
15 python37Packages.yapf
16 hlint
17 ocamlformat
18 ocamlPackages.ocaml-lsp
19 ];
20 plugins = with pkgs.vimPlugins; [
21 # neovim only
22 nvim-lspconfig
23 (nvim-treesitter.withPlugins (_: pkgs.tree-sitter.allGrammars))
24 completion-nvim
25
26 # tpope
27 vim-surround
28 vim-unimpaired
29 vim-repeat
30 # vim-fugitive
31
32 # syntax
33 rust-vim
34 vim-nix
35 vimtex
36
37 # handy
38 # vim-gitgutter
39 tabular
40 emmet-vim
41 vimwiki
42 fzf-vim
43 ];
44 };
45}