aboutsummaryrefslogtreecommitdiff
path: root/crates/completion/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/completion/Cargo.toml')
-rw-r--r--crates/completion/Cargo.toml30
1 files changed, 30 insertions, 0 deletions
diff --git a/crates/completion/Cargo.toml b/crates/completion/Cargo.toml
new file mode 100644
index 000000000..b79ee33f7
--- /dev/null
+++ b/crates/completion/Cargo.toml
@@ -0,0 +1,30 @@
1[package]
2name = "completion"
3version = "0.0.0"
4description = "TBD"
5license = "MIT OR Apache-2.0"
6authors = ["rust-analyzer developers"]
7edition = "2018"
8
9[lib]
10doctest = false
11
12[dependencies]
13itertools = "0.9.0"
14log = "0.4.8"
15rustc-hash = "1.1.0"
16
17stdx = { path = "../stdx", version = "0.0.0" }
18syntax = { path = "../syntax", version = "0.0.0" }
19text_edit = { path = "../text_edit", version = "0.0.0" }
20base_db = { path = "../base_db", version = "0.0.0" }
21ide_db = { path = "../ide_db", version = "0.0.0" }
22profile = { path = "../profile", version = "0.0.0" }
23test_utils = { path = "../test_utils", version = "0.0.0" }
24
25# completions crate should depend only on the top-level `hir` package. if you need
26# something from some `hir_xxx` subpackage, reexport the API via `hir`.
27hir = { path = "../hir", version = "0.0.0" }
28
29[dev-dependencies]
30expect-test = "1.0"