diff options
Diffstat (limited to 'crates/hir/Cargo.toml')
-rw-r--r-- | crates/hir/Cargo.toml | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/crates/hir/Cargo.toml b/crates/hir/Cargo.toml new file mode 100644 index 000000000..dbb2986b6 --- /dev/null +++ b/crates/hir/Cargo.toml | |||
@@ -0,0 +1,24 @@ | |||
1 | [package] | ||
2 | name = "hir" | ||
3 | version = "0.0.0" | ||
4 | license = "MIT OR Apache-2.0" | ||
5 | authors = ["rust-analyzer developers"] | ||
6 | edition = "2018" | ||
7 | |||
8 | [lib] | ||
9 | doctest = false | ||
10 | |||
11 | [dependencies] | ||
12 | log = "0.4.8" | ||
13 | rustc-hash = "1.1.0" | ||
14 | either = "1.5.3" | ||
15 | arrayvec = "0.5.1" | ||
16 | itertools = "0.9.0" | ||
17 | |||
18 | stdx = { path = "../stdx" } | ||
19 | syntax = { path = "../syntax" } | ||
20 | base_db = { path = "../base_db" } | ||
21 | profile = { path = "../profile" } | ||
22 | hir_expand = { path = "../hir_expand" } | ||
23 | hir_def = { path = "../hir_def" } | ||
24 | hir_ty = { path = "../hir_ty" } | ||