aboutsummaryrefslogtreecommitdiff
path: root/crates/hir_def/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/hir_def/Cargo.toml')
-rw-r--r--crates/hir_def/Cargo.toml35
1 files changed, 35 insertions, 0 deletions
diff --git a/crates/hir_def/Cargo.toml b/crates/hir_def/Cargo.toml
new file mode 100644
index 000000000..403bc2aff
--- /dev/null
+++ b/crates/hir_def/Cargo.toml
@@ -0,0 +1,35 @@
1[package]
2name = "hir_def"
3version = "0.0.0"
4license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"]
6edition = "2018"
7
8[lib]
9doctest = false
10
11[dependencies]
12log = "0.4.8"
13once_cell = "1.3.1"
14rustc-hash = "1.1.0"
15either = "1.5.3"
16anymap = "0.12.1"
17drop_bomb = "0.1.4"
18fst = { version = "0.4", default-features = false }
19itertools = "0.9.0"
20indexmap = "1.4.0"
21smallvec = "1.4.0"
22
23stdx = { path = "../stdx" }
24arena = { path = "../arena" }
25base_db = { path = "../base_db" }
26syntax = { path = "../syntax" }
27profile = { path = "../profile" }
28hir_expand = { path = "../hir_expand" }
29test_utils = { path = "../test_utils" }
30mbe = { path = "../mbe" }
31cfg = { path = "../cfg" }
32tt = { path = "../tt" }
33
34[dev-dependencies]
35expect = { path = "../expect" }