aboutsummaryrefslogtreecommitdiff
path: root/crates/hir_ty/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/hir_ty/Cargo.toml')
-rw-r--r--crates/hir_ty/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/crates/hir_ty/Cargo.toml b/crates/hir_ty/Cargo.toml
new file mode 100644
index 000000000..a319b0ce8
--- /dev/null
+++ b/crates/hir_ty/Cargo.toml
@@ -0,0 +1,37 @@
1[package]
2name = "hir_ty"
3version = "0.0.0"
4license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"]
6edition = "2018"
7
8[lib]
9doctest = false
10
11[dependencies]
12itertools = "0.9.0"
13arrayvec = "0.5.1"
14smallvec = "1.2.0"
15ena = "0.14.0"
16log = "0.4.8"
17rustc-hash = "1.1.0"
18scoped-tls = "1"
19chalk-solve = { version = "0.23.0" }
20chalk-ir = { version = "0.23.0" }
21chalk-recursive = { version = "0.23.0" }
22
23stdx = { path = "../stdx" }
24hir_def = { path = "../hir_def" }
25hir_expand = { path = "../hir_expand" }
26arena = { path = "../arena" }
27base_db = { path = "../base_db" }
28profile = { path = "../profile" }
29syntax = { path = "../syntax" }
30test_utils = { path = "../test_utils" }
31
32[dev-dependencies]
33tracing = "0.1"
34tracing-subscriber = { version = "0.2", default-features = false, features = ["env-filter", "registry"] }
35tracing-tree = { version = "0.1.4" }
36
37expect = { path = "../expect" }