aboutsummaryrefslogtreecommitdiff
path: root/crates/hir_ty/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/hir_ty/Cargo.toml')
-rw-r--r--crates/hir_ty/Cargo.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/crates/hir_ty/Cargo.toml b/crates/hir_ty/Cargo.toml
index d1302d749..b9c93f56f 100644
--- a/crates/hir_ty/Cargo.toml
+++ b/crates/hir_ty/Cargo.toml
@@ -10,6 +10,7 @@ edition = "2018"
10doctest = false 10doctest = false
11 11
12[dependencies] 12[dependencies]
13cov-mark = "1.1"
13itertools = "0.10.0" 14itertools = "0.10.0"
14arrayvec = "0.5.1" 15arrayvec = "0.5.1"
15smallvec = "1.2.0" 16smallvec = "1.2.0"
@@ -17,9 +18,9 @@ ena = "0.14.0"
17log = "0.4.8" 18log = "0.4.8"
18rustc-hash = "1.1.0" 19rustc-hash = "1.1.0"
19scoped-tls = "1" 20scoped-tls = "1"
20chalk-solve = { version = "0.59", default-features = false } 21chalk-solve = { version = "0.60", default-features = false }
21chalk-ir = "0.59" 22chalk-ir = "0.60"
22chalk-recursive = "0.59" 23chalk-recursive = "0.60"
23la-arena = { version = "0.2.0", path = "../../lib/arena" } 24la-arena = { version = "0.2.0", path = "../../lib/arena" }
24 25
25stdx = { path = "../stdx", version = "0.0.0" } 26stdx = { path = "../stdx", version = "0.0.0" }
@@ -28,9 +29,9 @@ hir_expand = { path = "../hir_expand", version = "0.0.0" }
28base_db = { path = "../base_db", version = "0.0.0" } 29base_db = { path = "../base_db", version = "0.0.0" }
29profile = { path = "../profile", version = "0.0.0" } 30profile = { path = "../profile", version = "0.0.0" }
30syntax = { path = "../syntax", version = "0.0.0" } 31syntax = { path = "../syntax", version = "0.0.0" }
31test_utils = { path = "../test_utils", version = "0.0.0" }
32 32
33[dev-dependencies] 33[dev-dependencies]
34test_utils = { path = "../test_utils" }
34expect-test = "1.1" 35expect-test = "1.1"
35tracing = "0.1" 36tracing = "0.1"
36tracing-subscriber = { version = "0.2", default-features = false, features = ["env-filter", "registry"] } 37tracing-subscriber = { version = "0.2", default-features = false, features = ["env-filter", "registry"] }