diff options
Diffstat (limited to 'crates/hir_ty/Cargo.toml')
-rw-r--r-- | crates/hir_ty/Cargo.toml | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/crates/hir_ty/Cargo.toml b/crates/hir_ty/Cargo.toml new file mode 100644 index 000000000..83b5013a9 --- /dev/null +++ b/crates/hir_ty/Cargo.toml | |||
@@ -0,0 +1,37 @@ | |||
1 | [package] | ||
2 | name = "hir_ty" | ||
3 | version = "0.0.0" | ||
4 | license = "MIT OR Apache-2.0" | ||
5 | authors = ["rust-analyzer developers"] | ||
6 | edition = "2018" | ||
7 | |||
8 | [lib] | ||
9 | doctest = false | ||
10 | |||
11 | [dependencies] | ||
12 | itertools = "0.9.0" | ||
13 | arrayvec = "0.5.1" | ||
14 | smallvec = "1.2.0" | ||
15 | ena = "0.14.0" | ||
16 | log = "0.4.8" | ||
17 | rustc-hash = "1.1.0" | ||
18 | scoped-tls = "1" | ||
19 | chalk-solve = { version = "0.21.0" } | ||
20 | chalk-ir = { version = "0.21.0" } | ||
21 | chalk-recursive = { version = "0.21.0" } | ||
22 | |||
23 | stdx = { path = "../stdx" } | ||
24 | hir_def = { path = "../hir_def" } | ||
25 | hir_expand = { path = "../hir_expand" } | ||
26 | arena = { path = "../arena" } | ||
27 | base_db = { path = "../base_db" } | ||
28 | profile = { path = "../profile" } | ||
29 | syntax = { path = "../syntax" } | ||
30 | test_utils = { path = "../test_utils" } | ||
31 | |||
32 | [dev-dependencies] | ||
33 | tracing = "0.1" | ||
34 | tracing-subscriber = { version = "0.2", default-features = false, features = ["env-filter", "registry"] } | ||
35 | tracing-tree = { version = "0.1.4" } | ||
36 | |||
37 | expect = { path = "../expect" } | ||