aboutsummaryrefslogtreecommitdiff
path: root/crates/ide_assists/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ide_assists/Cargo.toml')
-rw-r--r--crates/ide_assists/Cargo.toml26
1 files changed, 26 insertions, 0 deletions
diff --git a/crates/ide_assists/Cargo.toml b/crates/ide_assists/Cargo.toml
new file mode 100644
index 000000000..a34bdd6c3
--- /dev/null
+++ b/crates/ide_assists/Cargo.toml
@@ -0,0 +1,26 @@
1[package]
2name = "ide_assists"
3version = "0.0.0"
4description = "TBD"
5license = "MIT OR Apache-2.0"
6authors = ["rust-analyzer developers"]
7edition = "2018"
8
9[lib]
10doctest = false
11
12[dependencies]
13rustc-hash = "1.1.0"
14itertools = "0.10.0"
15either = "1.6.1"
16
17stdx = { path = "../stdx", version = "0.0.0" }
18syntax = { path = "../syntax", version = "0.0.0" }
19text_edit = { path = "../text_edit", version = "0.0.0" }
20profile = { path = "../profile", version = "0.0.0" }
21ide_db = { path = "../ide_db", version = "0.0.0" }
22hir = { path = "../hir", version = "0.0.0" }
23test_utils = { path = "../test_utils", version = "0.0.0" }
24
25[dev-dependencies]
26expect-test = "1.1"