aboutsummaryrefslogtreecommitdiff
path: root/crates/ide_db/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ide_db/Cargo.toml')
-rw-r--r--crates/ide_db/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/crates/ide_db/Cargo.toml b/crates/ide_db/Cargo.toml
index d4612a75e..1f7a90d20 100644
--- a/crates/ide_db/Cargo.toml
+++ b/crates/ide_db/Cargo.toml
@@ -10,6 +10,7 @@ edition = "2018"
10doctest = false 10doctest = false
11 11
12[dependencies] 12[dependencies]
13cov-mark = "1.1"
13log = "0.4.8" 14log = "0.4.8"
14rayon = "1.5.0" 15rayon = "1.5.0"
15fst = { version = "0.4", default-features = false } 16fst = { version = "0.4", default-features = false }
@@ -23,10 +24,10 @@ syntax = { path = "../syntax", version = "0.0.0" }
23text_edit = { path = "../text_edit", version = "0.0.0" } 24text_edit = { path = "../text_edit", version = "0.0.0" }
24base_db = { path = "../base_db", version = "0.0.0" } 25base_db = { path = "../base_db", version = "0.0.0" }
25profile = { path = "../profile", version = "0.0.0" } 26profile = { path = "../profile", version = "0.0.0" }
26test_utils = { path = "../test_utils", version = "0.0.0" }
27# ide should depend only on the top-level `hir` package. if you need 27# ide should depend only on the top-level `hir` package. if you need
28# something from some `hir_xxx` subpackage, reexport the API via `hir`. 28# something from some `hir_xxx` subpackage, reexport the API via `hir`.
29hir = { path = "../hir", version = "0.0.0" } 29hir = { path = "../hir", version = "0.0.0" }
30 30
31[dev-dependencies] 31[dev-dependencies]
32test_utils = { path = "../test_utils" }
32expect-test = "1.1" 33expect-test = "1.1"