aboutsummaryrefslogtreecommitdiff
path: root/crates/ide_helpers/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ide_helpers/Cargo.toml')
-rw-r--r--crates/ide_helpers/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/crates/ide_helpers/Cargo.toml b/crates/ide_helpers/Cargo.toml
new file mode 100644
index 000000000..c5065b22b
--- /dev/null
+++ b/crates/ide_helpers/Cargo.toml
@@ -0,0 +1,23 @@
1[package]
2name = "ide_helpers"
3version = "0.0.0"
4description = "A set of helper methods shared between various ide-level modules"
5license = "MIT OR Apache-2.0"
6authors = ["rust-analyzer developers"]
7edition = "2018"
8
9[lib]
10doctest = false
11
12[features]
13wasm = []
14
15[dependencies]
16either = "1.6.1"
17itertools = "0.9.0"
18
19syntax = { path = "../syntax", version = "0.0.0" }
20ide_db = { path = "../ide_db", version = "0.0.0" }
21hir = { path = "../hir", version = "0.0.0" }
22profile = { path = "../profile", version = "0.0.0" }
23test_utils = { path = "../test_utils", version = "0.0.0" }