aboutsummaryrefslogtreecommitdiff
path: root/crates/proc_macro_srv/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/proc_macro_srv/Cargo.toml')
-rw-r--r--crates/proc_macro_srv/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/crates/proc_macro_srv/Cargo.toml b/crates/proc_macro_srv/Cargo.toml
new file mode 100644
index 000000000..0954ffb66
--- /dev/null
+++ b/crates/proc_macro_srv/Cargo.toml
@@ -0,0 +1,27 @@
1[package]
2name = "proc_macro_srv"
3version = "0.0.0"
4license = "MIT OR Apache-2.0"
5authors = ["rust-analyzer developers"]
6edition = "2018"
7
8[lib]
9doctest = false
10
11[dependencies]
12goblin = "0.2.1"
13libloading = "0.6.0"
14memmap = "0.7"
15
16tt = { path = "../tt" }
17mbe = { path = "../mbe" }
18ra_proc_macro = { path = "../ra_proc_macro" }
19test_utils = { path = "../test_utils" }
20
21[dev-dependencies]
22cargo_metadata = "0.11.1"
23difference = "2.0.0"
24# used as proc macro test target
25serde_derive = "1.0.106"
26
27toolchain = { path = "../toolchain" }