aboutsummaryrefslogtreecommitdiff
path: root/crates/profile/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/profile/Cargo.toml')
-rw-r--r--crates/profile/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/crates/profile/Cargo.toml b/crates/profile/Cargo.toml
index 9c7ce26be..cc7da27f7 100644
--- a/crates/profile/Cargo.toml
+++ b/crates/profile/Cargo.toml
@@ -14,12 +14,15 @@ once_cell = "1.3.1"
14cfg-if = "1" 14cfg-if = "1"
15libc = "0.2.73" 15libc = "0.2.73"
16la-arena = { version = "0.2.0", path = "../../lib/arena" } 16la-arena = { version = "0.2.0", path = "../../lib/arena" }
17countme = { version = "2.0.0-pre.2", features = ["enable"] }
18jemalloc-ctl = { version = "0.3.3", optional = true }
17 19
18[target.'cfg(target_os = "linux")'.dependencies] 20[target.'cfg(target_os = "linux")'.dependencies]
19perf-event = "0.4" 21perf-event = "0.4"
20 22
21[features] 23[features]
22cpu_profiler = [] 24cpu_profiler = []
25jemalloc = ["jemalloc-ctl"]
23 26
24# Uncomment to enable for the whole crate graph 27# Uncomment to enable for the whole crate graph
25# default = [ "cpu_profiler" ] 28# default = [ "cpu_profiler" ]