aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_hir_ty/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_hir_ty/Cargo.toml')
-rw-r--r--crates/ra_hir_ty/Cargo.toml40
1 files changed, 0 insertions, 40 deletions
diff --git a/crates/ra_hir_ty/Cargo.toml b/crates/ra_hir_ty/Cargo.toml
deleted file mode 100644
index d430b08ca..000000000
--- a/crates/ra_hir_ty/Cargo.toml
+++ /dev/null
@@ -1,40 +0,0 @@
1[package]
2edition = "2018"
3name = "ra_hir_ty"
4version = "0.1.0"
5authors = ["rust-analyzer developers"]
6license = "MIT OR Apache-2.0"
7
8[lib]
9doctest = false
10
11[dependencies]
12itertools = "0.9.0"
13arrayvec = "0.5.1"
14smallvec = "1.2.0"
15ena = "0.14.0"
16log = "0.4.8"
17rustc-hash = "1.1.0"
18
19stdx = { path = "../stdx" }
20
21hir_def = { path = "../hir_def" }
22hir_expand = { path = "../hir_expand" }
23arena = { path = "../arena" }
24base_db = { path = "../base_db" }
25profile = { path = "../profile" }
26syntax = { path = "../syntax" }
27test_utils = { path = "../test_utils" }
28
29scoped-tls = "1"
30
31chalk-solve = { version = "0.21.0" }
32chalk-ir = { version = "0.21.0" }
33chalk-recursive = { version = "0.21.0" }
34
35[dev-dependencies]
36expect = { path = "../expect" }
37
38tracing = "0.1"
39tracing-subscriber = { version = "0.2", default-features = false, features = ["env-filter", "registry"] }
40tracing-tree = { version = "0.1.4" }