diff options
Diffstat (limited to 'crates/ra_ide/Cargo.toml')
-rw-r--r-- | crates/ra_ide/Cargo.toml | 20 |
1 files changed, 12 insertions, 8 deletions
diff --git a/crates/ra_ide/Cargo.toml b/crates/ra_ide/Cargo.toml index 97dea5ffd..3407d2598 100644 --- a/crates/ra_ide/Cargo.toml +++ b/crates/ra_ide/Cargo.toml | |||
@@ -11,15 +11,19 @@ doctest = false | |||
11 | wasm = [] | 11 | wasm = [] |
12 | 12 | ||
13 | [dependencies] | 13 | [dependencies] |
14 | either = "1.5" | 14 | either = "1.5.3" |
15 | format-buf = "1.0.0" | 15 | format-buf = "1.0.0" |
16 | indexmap = "1.3.0" | 16 | indexmap = "1.3.2" |
17 | itertools = "0.8.0" | 17 | itertools = "0.8.2" |
18 | join_to_string = "0.1.3" | 18 | join_to_string = "0.1.3" |
19 | log = "0.4.5" | 19 | log = "0.4.8" |
20 | rustc-hash = "1.0" | 20 | rayon = "1.3.0" |
21 | rand = { version = "0.7.0", features = ["small_rng"] } | 21 | fst = { version = "0.3.5", default-features = false } |
22 | once_cell = "1.2.0" | 22 | rustc-hash = "1.1.0" |
23 | unicase = "2.6.0" | ||
24 | superslice = "1.0.0" | ||
25 | rand = { version = "0.7.3", features = ["small_rng"] } | ||
26 | once_cell = "1.3.1" | ||
23 | 27 | ||
24 | ra_syntax = { path = "../ra_syntax" } | 28 | ra_syntax = { path = "../ra_syntax" } |
25 | ra_text_edit = { path = "../ra_text_edit" } | 29 | ra_text_edit = { path = "../ra_text_edit" } |
@@ -36,4 +40,4 @@ ra_assists = { path = "../ra_assists" } | |||
36 | hir = { path = "../ra_hir", package = "ra_hir" } | 40 | hir = { path = "../ra_hir", package = "ra_hir" } |
37 | 41 | ||
38 | [dev-dependencies] | 42 | [dev-dependencies] |
39 | insta = "0.13.0" | 43 | insta = "0.13.1" |