aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_ide/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_ide/Cargo.toml')
-rw-r--r--crates/ra_ide/Cargo.toml6
1 files changed, 1 insertions, 5 deletions
diff --git a/crates/ra_ide/Cargo.toml b/crates/ra_ide/Cargo.toml
index 485aa9081..de606f57e 100644
--- a/crates/ra_ide/Cargo.toml
+++ b/crates/ra_ide/Cargo.toml
@@ -17,10 +17,9 @@ indexmap = "1.3.2"
17itertools = "0.9.0" 17itertools = "0.9.0"
18log = "0.4.8" 18log = "0.4.8"
19rustc-hash = "1.1.0" 19rustc-hash = "1.1.0"
20url = "2.1.1" 20oorandom = "11.1.2"
21pulldown-cmark-to-cmark = "5.0.0" 21pulldown-cmark-to-cmark = "5.0.0"
22pulldown-cmark = {version = "0.7.2", default-features = false} 22pulldown-cmark = {version = "0.7.2", default-features = false}
23oorandom = "11.1.2"
24 23
25stdx = { path = "../stdx" } 24stdx = { path = "../stdx" }
26 25
@@ -34,9 +33,6 @@ ra_prof = { path = "../ra_prof" }
34test_utils = { path = "../test_utils" } 33test_utils = { path = "../test_utils" }
35ra_assists = { path = "../ra_assists" } 34ra_assists = { path = "../ra_assists" }
36ra_ssr = { path = "../ra_ssr" } 35ra_ssr = { path = "../ra_ssr" }
37ra_hir_def = { path = "../ra_hir_def" }
38ra_tt = { path = "../ra_tt" }
39ra_parser = { path = "../ra_parser" }
40 36
41# ra_ide should depend only on the top-level `hir` package. if you need 37# ra_ide should depend only on the top-level `hir` package. if you need
42# something from some `hir_xxx` subpackage, reexport the API via `hir`. 38# something from some `hir_xxx` subpackage, reexport the API via `hir`.