aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_ide/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_ide/Cargo.toml')
-rw-r--r--crates/ra_ide/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/crates/ra_ide/Cargo.toml b/crates/ra_ide/Cargo.toml
index 05c940605..6f8107491 100644
--- a/crates/ra_ide/Cargo.toml
+++ b/crates/ra_ide/Cargo.toml
@@ -3,6 +3,7 @@ edition = "2018"
3name = "ra_ide" 3name = "ra_ide"
4version = "0.1.0" 4version = "0.1.0"
5authors = ["rust-analyzer developers"] 5authors = ["rust-analyzer developers"]
6license = "MIT OR Apache-2.0"
6 7
7[lib] 8[lib]
8doctest = false 9doctest = false
@@ -29,10 +30,11 @@ ra_fmt = { path = "../ra_fmt" }
29ra_prof = { path = "../ra_prof" } 30ra_prof = { path = "../ra_prof" }
30test_utils = { path = "../test_utils" } 31test_utils = { path = "../test_utils" }
31ra_assists = { path = "../ra_assists" } 32ra_assists = { path = "../ra_assists" }
33ra_ssr = { path = "../ra_ssr" }
32 34
33# ra_ide should depend only on the top-level `hir` package. if you need 35# ra_ide should depend only on the top-level `hir` package. if you need
34# something from some `hir_xxx` subpackage, reexport the API via `hir`. 36# something from some `hir_xxx` subpackage, reexport the API via `hir`.
35hir = { path = "../ra_hir", package = "ra_hir" } 37hir = { path = "../ra_hir", package = "ra_hir" }
36 38
37[dev-dependencies] 39[dev-dependencies]
38insta = "0.16.0" 40expect = { path = "../expect" }