aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_ide_api/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_ide_api/Cargo.toml')
-rw-r--r--crates/ra_ide_api/Cargo.toml10
1 files changed, 8 insertions, 2 deletions
diff --git a/crates/ra_ide_api/Cargo.toml b/crates/ra_ide_api/Cargo.toml
index ac8c8057b..c64226801 100644
--- a/crates/ra_ide_api/Cargo.toml
+++ b/crates/ra_ide_api/Cargo.toml
@@ -10,7 +10,7 @@ join_to_string = "0.1.3"
10log = "0.4.5" 10log = "0.4.5"
11relative-path = "0.4.0" 11relative-path = "0.4.0"
12rayon = "1.0.2" 12rayon = "1.0.2"
13fst = "0.3.1" 13fst = { version = "0.3.1", default-features = false }
14rustc-hash = "1.0" 14rustc-hash = "1.0"
15parking_lot = "0.7.0" 15parking_lot = "0.7.0"
16unicase = "2.2.0" 16unicase = "2.2.0"
@@ -23,13 +23,19 @@ ra_syntax = { path = "../ra_syntax" }
23ra_ide_api_light = { path = "../ra_ide_api_light" } 23ra_ide_api_light = { path = "../ra_ide_api_light" }
24ra_text_edit = { path = "../ra_text_edit" } 24ra_text_edit = { path = "../ra_text_edit" }
25ra_db = { path = "../ra_db" } 25ra_db = { path = "../ra_db" }
26ra_fmt = { path = "../ra_fmt" }
26hir = { path = "../ra_hir", package = "ra_hir" } 27hir = { path = "../ra_hir", package = "ra_hir" }
27test_utils = { path = "../test_utils" } 28test_utils = { path = "../test_utils" }
28ra_assists = { path = "../ra_assists" } 29ra_assists = { path = "../ra_assists" }
29 30
30[dev-dependencies] 31[dev-dependencies]
31insta = "0.7.0" 32insta = "0.7.0"
32proptest = "0.9.0" 33
34[dev-dependencies.proptest]
35version = "0.9.0"
36# Disable `fork` feature to allow compiling on webassembly
37default-features = false
38features = ["std", "bit-set", "break-dead-code"]
33 39
34[features] 40[features]
35jemalloc = [ "jemallocator", "jemalloc-ctl" ] 41jemalloc = [ "jemallocator", "jemalloc-ctl" ]