diff options
Diffstat (limited to 'crates/ra_ide_db/Cargo.toml')
-rw-r--r-- | crates/ra_ide_db/Cargo.toml | 13 |
1 files changed, 0 insertions, 13 deletions
diff --git a/crates/ra_ide_db/Cargo.toml b/crates/ra_ide_db/Cargo.toml index ee409e34e..7b285d280 100644 --- a/crates/ra_ide_db/Cargo.toml +++ b/crates/ra_ide_db/Cargo.toml | |||
@@ -11,30 +11,17 @@ doctest = false | |||
11 | wasm = [] | 11 | wasm = [] |
12 | 12 | ||
13 | [dependencies] | 13 | [dependencies] |
14 | either = "1.5.3" | ||
15 | format-buf = "1.0.0" | ||
16 | indexmap = "1.3.2" | ||
17 | itertools = "0.8.2" | ||
18 | join_to_string = "0.1.3" | ||
19 | log = "0.4.8" | 14 | log = "0.4.8" |
20 | rayon = "1.3.0" | 15 | rayon = "1.3.0" |
21 | fst = { version = "0.3.5", default-features = false } | 16 | fst = { version = "0.3.5", default-features = false } |
22 | rustc-hash = "1.1.0" | 17 | rustc-hash = "1.1.0" |
23 | unicase = "2.6.0" | ||
24 | superslice = "1.0.0" | 18 | superslice = "1.0.0" |
25 | once_cell = "1.3.1" | ||
26 | 19 | ||
27 | ra_syntax = { path = "../ra_syntax" } | 20 | ra_syntax = { path = "../ra_syntax" } |
28 | ra_text_edit = { path = "../ra_text_edit" } | 21 | ra_text_edit = { path = "../ra_text_edit" } |
29 | ra_db = { path = "../ra_db" } | 22 | ra_db = { path = "../ra_db" } |
30 | ra_cfg = { path = "../ra_cfg" } | ||
31 | ra_fmt = { path = "../ra_fmt" } | ||
32 | ra_prof = { path = "../ra_prof" } | 23 | ra_prof = { path = "../ra_prof" } |
33 | test_utils = { path = "../test_utils" } | ||
34 | 24 | ||
35 | # ra_ide should depend only on the top-level `hir` package. if you need | 25 | # ra_ide should depend only on the top-level `hir` package. if you need |
36 | # something from some `hir_xxx` subpackage, reexport the API via `hir`. | 26 | # something from some `hir_xxx` subpackage, reexport the API via `hir`. |
37 | hir = { path = "../ra_hir", package = "ra_hir" } | 27 | hir = { path = "../ra_hir", package = "ra_hir" } |
38 | |||
39 | [dev-dependencies] | ||
40 | insta = "0.13.1" | ||