aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_ide_db/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_ide_db/Cargo.toml')
-rw-r--r--crates/ra_ide_db/Cargo.toml13
1 files changed, 0 insertions, 13 deletions
diff --git a/crates/ra_ide_db/Cargo.toml b/crates/ra_ide_db/Cargo.toml
index ee409e34e..7b285d280 100644
--- a/crates/ra_ide_db/Cargo.toml
+++ b/crates/ra_ide_db/Cargo.toml
@@ -11,30 +11,17 @@ doctest = false
11wasm = [] 11wasm = []
12 12
13[dependencies] 13[dependencies]
14either = "1.5.3"
15format-buf = "1.0.0"
16indexmap = "1.3.2"
17itertools = "0.8.2"
18join_to_string = "0.1.3"
19log = "0.4.8" 14log = "0.4.8"
20rayon = "1.3.0" 15rayon = "1.3.0"
21fst = { version = "0.3.5", default-features = false } 16fst = { version = "0.3.5", default-features = false }
22rustc-hash = "1.1.0" 17rustc-hash = "1.1.0"
23unicase = "2.6.0"
24superslice = "1.0.0" 18superslice = "1.0.0"
25once_cell = "1.3.1"
26 19
27ra_syntax = { path = "../ra_syntax" } 20ra_syntax = { path = "../ra_syntax" }
28ra_text_edit = { path = "../ra_text_edit" } 21ra_text_edit = { path = "../ra_text_edit" }
29ra_db = { path = "../ra_db" } 22ra_db = { path = "../ra_db" }
30ra_cfg = { path = "../ra_cfg" }
31ra_fmt = { path = "../ra_fmt" }
32ra_prof = { path = "../ra_prof" } 23ra_prof = { path = "../ra_prof" }
33test_utils = { path = "../test_utils" }
34 24
35# ra_ide should depend only on the top-level `hir` package. if you need 25# ra_ide should depend only on the top-level `hir` package. if you need
36# something from some `hir_xxx` subpackage, reexport the API via `hir`. 26# something from some `hir_xxx` subpackage, reexport the API via `hir`.
37hir = { path = "../ra_hir", package = "ra_hir" } 27hir = { path = "../ra_hir", package = "ra_hir" }
38
39[dev-dependencies]
40insta = "0.13.1"