diff options
Diffstat (limited to 'crates/ra_lsp_server/Cargo.toml')
-rw-r--r-- | crates/ra_lsp_server/Cargo.toml | 29 |
1 files changed, 15 insertions, 14 deletions
diff --git a/crates/ra_lsp_server/Cargo.toml b/crates/ra_lsp_server/Cargo.toml index fdf81ed87..0066929c0 100644 --- a/crates/ra_lsp_server/Cargo.toml +++ b/crates/ra_lsp_server/Cargo.toml | |||
@@ -8,27 +8,28 @@ authors = ["rust-analyzer developers"] | |||
8 | doctest = false | 8 | doctest = false |
9 | 9 | ||
10 | [dependencies] | 10 | [dependencies] |
11 | threadpool = "1.7.1" | ||
12 | relative-path = "1.0.0" | ||
13 | serde_json = "1.0.34" | ||
14 | serde = { version = "1.0.83", features = ["derive"] } | ||
15 | crossbeam-channel = "0.4" | 11 | crossbeam-channel = "0.4" |
12 | either = "1.5" | ||
13 | env_logger = { version = "0.7.1", default-features = false } | ||
14 | jod-thread = "0.1.0" | ||
16 | log = "0.4.3" | 15 | log = "0.4.3" |
17 | lsp-types = { version = "0.70.0", features = ["proposed"] } | 16 | lsp-types = { version = "0.70.0", features = ["proposed"] } |
18 | rustc-hash = "1.0" | ||
19 | parking_lot = "0.10.0" | 17 | parking_lot = "0.10.0" |
20 | jod-thread = "0.1.0" | 18 | relative-path = "1.0.0" |
21 | ra_vfs = "0.5.0" | 19 | rustc-hash = "1.0" |
22 | ra_syntax = { path = "../ra_syntax" } | 20 | serde = { version = "1.0.83", features = ["derive"] } |
23 | ra_text_edit = { path = "../ra_text_edit" } | 21 | serde_json = "1.0.34" |
24 | ra_ide = { path = "../ra_ide" } | 22 | threadpool = "1.7.1" |
23 | |||
25 | lsp-server = "0.3.0" | 24 | lsp-server = "0.3.0" |
26 | ra_project_model = { path = "../ra_project_model" } | 25 | ra_cargo_watch = { path = "../ra_cargo_watch" } |
26 | ra_ide = { path = "../ra_ide" } | ||
27 | ra_prof = { path = "../ra_prof" } | 27 | ra_prof = { path = "../ra_prof" } |
28 | ra_project_model = { path = "../ra_project_model" } | ||
29 | ra_syntax = { path = "../ra_syntax" } | ||
30 | ra_text_edit = { path = "../ra_text_edit" } | ||
31 | ra_vfs = "0.5.0" | ||
28 | ra_vfs_glob = { path = "../ra_vfs_glob" } | 32 | ra_vfs_glob = { path = "../ra_vfs_glob" } |
29 | env_logger = { version = "0.7.1", default-features = false } | ||
30 | ra_cargo_watch = { path = "../ra_cargo_watch" } | ||
31 | either = "1.5" | ||
32 | 33 | ||
33 | [target.'cfg(windows)'.dependencies] | 34 | [target.'cfg(windows)'.dependencies] |
34 | winapi = "0.3" | 35 | winapi = "0.3" |