aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_lsp_server/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_lsp_server/Cargo.toml')
-rw-r--r--crates/ra_lsp_server/Cargo.toml53
1 files changed, 0 insertions, 53 deletions
diff --git a/crates/ra_lsp_server/Cargo.toml b/crates/ra_lsp_server/Cargo.toml
deleted file mode 100644
index da523ba8a..000000000
--- a/crates/ra_lsp_server/Cargo.toml
+++ /dev/null
@@ -1,53 +0,0 @@
1[package]
2edition = "2018"
3name = "ra_lsp_server"
4version = "0.1.0"
5authors = ["rust-analyzer developers"]
6
7[lib]
8doctest = false
9
10[dependencies]
11anyhow = "1.0"
12crossbeam-channel = "0.4"
13either = "1.5"
14env_logger = { version = "0.7.1", default-features = false }
15globset = "0.4.4"
16itertools = "0.8.0"
17jod-thread = "0.1.0"
18log = "0.4.3"
19lsp-types = { version = "0.70.0", features = ["proposed"] }
20parking_lot = "0.10.0"
21pico-args = "0.3.0"
22rand = { version = "0.7.0", features = ["small_rng"] }
23relative-path = "1.0.0"
24rustc-hash = "1.0"
25serde = { version = "1.0.83", features = ["derive"] }
26serde_json = "1.0.34"
27threadpool = "1.7.1"
28
29lsp-server = "0.3.0"
30ra_cargo_watch = { path = "../ra_cargo_watch" }
31ra_ide = { path = "../ra_ide" }
32ra_prof = { path = "../ra_prof" }
33ra_project_model = { path = "../ra_project_model" }
34ra_syntax = { path = "../ra_syntax" }
35ra_text_edit = { path = "../ra_text_edit" }
36ra_vfs = "0.5.0"
37
38# This should only be used in CLI
39ra_db = { path = "../ra_db" }
40hir = { path = "../ra_hir", package = "ra_hir" }
41hir_def = { path = "../ra_hir_def", package = "ra_hir_def" }
42hir_ty = { path = "../ra_hir_ty", package = "ra_hir_ty" }
43
44
45[target.'cfg(windows)'.dependencies]
46winapi = "0.3"
47
48[dev-dependencies]
49tempfile = "3"
50test_utils = { path = "../test_utils" }
51
52[features]
53jemalloc = [ "ra_prof/jemalloc" ]