diff options
Diffstat (limited to 'crates/ra_lsp_server/Cargo.toml')
-rw-r--r-- | crates/ra_lsp_server/Cargo.toml | 53 |
1 files changed, 0 insertions, 53 deletions
diff --git a/crates/ra_lsp_server/Cargo.toml b/crates/ra_lsp_server/Cargo.toml deleted file mode 100644 index da523ba8a..000000000 --- a/crates/ra_lsp_server/Cargo.toml +++ /dev/null | |||
@@ -1,53 +0,0 @@ | |||
1 | [package] | ||
2 | edition = "2018" | ||
3 | name = "ra_lsp_server" | ||
4 | version = "0.1.0" | ||
5 | authors = ["rust-analyzer developers"] | ||
6 | |||
7 | [lib] | ||
8 | doctest = false | ||
9 | |||
10 | [dependencies] | ||
11 | anyhow = "1.0" | ||
12 | crossbeam-channel = "0.4" | ||
13 | either = "1.5" | ||
14 | env_logger = { version = "0.7.1", default-features = false } | ||
15 | globset = "0.4.4" | ||
16 | itertools = "0.8.0" | ||
17 | jod-thread = "0.1.0" | ||
18 | log = "0.4.3" | ||
19 | lsp-types = { version = "0.70.0", features = ["proposed"] } | ||
20 | parking_lot = "0.10.0" | ||
21 | pico-args = "0.3.0" | ||
22 | rand = { version = "0.7.0", features = ["small_rng"] } | ||
23 | relative-path = "1.0.0" | ||
24 | rustc-hash = "1.0" | ||
25 | serde = { version = "1.0.83", features = ["derive"] } | ||
26 | serde_json = "1.0.34" | ||
27 | threadpool = "1.7.1" | ||
28 | |||
29 | lsp-server = "0.3.0" | ||
30 | ra_cargo_watch = { path = "../ra_cargo_watch" } | ||
31 | ra_ide = { path = "../ra_ide" } | ||
32 | ra_prof = { path = "../ra_prof" } | ||
33 | ra_project_model = { path = "../ra_project_model" } | ||
34 | ra_syntax = { path = "../ra_syntax" } | ||
35 | ra_text_edit = { path = "../ra_text_edit" } | ||
36 | ra_vfs = "0.5.0" | ||
37 | |||
38 | # This should only be used in CLI | ||
39 | ra_db = { path = "../ra_db" } | ||
40 | hir = { path = "../ra_hir", package = "ra_hir" } | ||
41 | hir_def = { path = "../ra_hir_def", package = "ra_hir_def" } | ||
42 | hir_ty = { path = "../ra_hir_ty", package = "ra_hir_ty" } | ||
43 | |||
44 | |||
45 | [target.'cfg(windows)'.dependencies] | ||
46 | winapi = "0.3" | ||
47 | |||
48 | [dev-dependencies] | ||
49 | tempfile = "3" | ||
50 | test_utils = { path = "../test_utils" } | ||
51 | |||
52 | [features] | ||
53 | jemalloc = [ "ra_prof/jemalloc" ] | ||