aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_prof/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_prof/Cargo.toml')
-rw-r--r--crates/ra_prof/Cargo.toml10
1 files changed, 2 insertions, 8 deletions
diff --git a/crates/ra_prof/Cargo.toml b/crates/ra_prof/Cargo.toml
index b3d52985a..6c214501e 100644
--- a/crates/ra_prof/Cargo.toml
+++ b/crates/ra_prof/Cargo.toml
@@ -13,18 +13,12 @@ doctest = false
13ra_arena = { path = "../ra_arena" } 13ra_arena = { path = "../ra_arena" }
14once_cell = "1.3.1" 14once_cell = "1.3.1"
15backtrace = { version = "0.3.44", optional = true } 15backtrace = { version = "0.3.44", optional = true }
16mimalloc = { version = "0.1.19", default-features = false, optional = true } 16cfg-if = "0.1.10"
17 17libc = "0.2.73"
18[target.'cfg(not(target_env = "msvc"))'.dependencies]
19jemallocator = { version = "0.3.2", optional = true }
20jemalloc-ctl = { version = "0.3.3", optional = true }
21 18
22[features] 19[features]
23jemalloc = [ "jemallocator", "jemalloc-ctl" ]
24cpu_profiler = [] 20cpu_profiler = []
25 21
26# Uncomment to enable for the whole crate graph 22# Uncomment to enable for the whole crate graph
27# default = [ "backtrace" ] 23# default = [ "backtrace" ]
28# default = [ "jemalloc" ]
29# default = [ "mimalloc" ]
30# default = [ "cpu_profiler" ] 24# default = [ "cpu_profiler" ]