aboutsummaryrefslogtreecommitdiff
path: root/crates/ra_prof/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/ra_prof/Cargo.toml')
-rw-r--r--crates/ra_prof/Cargo.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/crates/ra_prof/Cargo.toml b/crates/ra_prof/Cargo.toml
index c33b5121a..b3d52985a 100644
--- a/crates/ra_prof/Cargo.toml
+++ b/crates/ra_prof/Cargo.toml
@@ -4,6 +4,7 @@ name = "ra_prof"
4version = "0.1.0" 4version = "0.1.0"
5authors = ["rust-analyzer developers"] 5authors = ["rust-analyzer developers"]
6publish = false 6publish = false
7license = "MIT OR Apache-2.0"
7 8
8[lib] 9[lib]
9doctest = false 10doctest = false
@@ -12,6 +13,7 @@ doctest = false
12ra_arena = { path = "../ra_arena" } 13ra_arena = { path = "../ra_arena" }
13once_cell = "1.3.1" 14once_cell = "1.3.1"
14backtrace = { version = "0.3.44", optional = true } 15backtrace = { version = "0.3.44", optional = true }
16mimalloc = { version = "0.1.19", default-features = false, optional = true }
15 17
16[target.'cfg(not(target_env = "msvc"))'.dependencies] 18[target.'cfg(not(target_env = "msvc"))'.dependencies]
17jemallocator = { version = "0.3.2", optional = true } 19jemallocator = { version = "0.3.2", optional = true }
@@ -20,3 +22,9 @@ jemalloc-ctl = { version = "0.3.3", optional = true }
20[features] 22[features]
21jemalloc = [ "jemallocator", "jemalloc-ctl" ] 23jemalloc = [ "jemallocator", "jemalloc-ctl" ]
22cpu_profiler = [] 24cpu_profiler = []
25
26# Uncomment to enable for the whole crate graph
27# default = [ "backtrace" ]
28# default = [ "jemalloc" ]
29# default = [ "mimalloc" ]
30# default = [ "cpu_profiler" ]