diff options
Diffstat (limited to 'crates/ra_syntax/Cargo.toml')
-rw-r--r-- | crates/ra_syntax/Cargo.toml | 12 |
1 files changed, 6 insertions, 6 deletions
diff --git a/crates/ra_syntax/Cargo.toml b/crates/ra_syntax/Cargo.toml index cb72972c5..7891628dc 100644 --- a/crates/ra_syntax/Cargo.toml +++ b/crates/ra_syntax/Cargo.toml | |||
@@ -11,12 +11,12 @@ repository = "https://github.com/rust-analyzer/rust-analyzer" | |||
11 | doctest = false | 11 | doctest = false |
12 | 12 | ||
13 | [dependencies] | 13 | [dependencies] |
14 | itertools = "0.8.0" | 14 | itertools = "0.8.2" |
15 | rowan = "0.9.0" | 15 | rowan = "0.9.0" |
16 | rustc_lexer = "0.1.0" | 16 | rustc_lexer = "0.1.0" |
17 | rustc-hash = "1.0.1" | 17 | rustc-hash = "1.1.0" |
18 | arrayvec = "0.5.1" | 18 | arrayvec = "0.5.1" |
19 | once_cell = "1.2.0" | 19 | once_cell = "1.3.1" |
20 | 20 | ||
21 | ra_text_edit = { path = "../ra_text_edit" } | 21 | ra_text_edit = { path = "../ra_text_edit" } |
22 | ra_parser = { path = "../ra_parser" } | 22 | ra_parser = { path = "../ra_parser" } |
@@ -24,9 +24,9 @@ ra_parser = { path = "../ra_parser" } | |||
24 | # This crate transitively depends on `smol_str` via `rowan`. | 24 | # This crate transitively depends on `smol_str` via `rowan`. |
25 | # ideally, `serde` should be enabled by `rust-analyzer`, but we enable it here | 25 | # ideally, `serde` should be enabled by `rust-analyzer`, but we enable it here |
26 | # to reduce number of compilations | 26 | # to reduce number of compilations |
27 | smol_str = { version = "0.1.12", features = ["serde"] } | 27 | smol_str = { version = "0.1.15", features = ["serde"] } |
28 | serde = { version = "1", features = ["derive"] } | 28 | serde = { version = "1.0.104", features = ["derive"] } |
29 | 29 | ||
30 | [dev-dependencies] | 30 | [dev-dependencies] |
31 | test_utils = { path = "../test_utils" } | 31 | test_utils = { path = "../test_utils" } |
32 | walkdir = "2.2.0" | 32 | walkdir = "2.3.1" |