diff options
Diffstat (limited to 'crates/ssr/Cargo.toml')
-rw-r--r-- | crates/ssr/Cargo.toml | 25 |
1 files changed, 25 insertions, 0 deletions
diff --git a/crates/ssr/Cargo.toml b/crates/ssr/Cargo.toml new file mode 100644 index 000000000..7c2090de3 --- /dev/null +++ b/crates/ssr/Cargo.toml | |||
@@ -0,0 +1,25 @@ | |||
1 | [package] | ||
2 | name = "ssr" | ||
3 | version = "0.0.0" | ||
4 | description = "Structural search and replace of Rust code" | ||
5 | license = "MIT OR Apache-2.0" | ||
6 | repository = "https://github.com/rust-analyzer/rust-analyzer" | ||
7 | authors = ["rust-analyzer developers"] | ||
8 | edition = "2018" | ||
9 | |||
10 | [lib] | ||
11 | doctest = false | ||
12 | |||
13 | [dependencies] | ||
14 | rustc-hash = "1.1.0" | ||
15 | itertools = "0.9.0" | ||
16 | |||
17 | text_edit = { path = "../text_edit" } | ||
18 | syntax = { path = "../syntax" } | ||
19 | base_db = { path = "../base_db" } | ||
20 | ide_db = { path = "../ide_db" } | ||
21 | hir = { path = "../hir" } | ||
22 | test_utils = { path = "../test_utils" } | ||
23 | |||
24 | [dev-dependencies] | ||
25 | expect = { path = "../expect" } | ||