diff options
Diffstat (limited to 'crates/syntax/fuzz/Cargo.toml')
-rw-r--r-- | crates/syntax/fuzz/Cargo.toml | 27 |
1 files changed, 27 insertions, 0 deletions
diff --git a/crates/syntax/fuzz/Cargo.toml b/crates/syntax/fuzz/Cargo.toml new file mode 100644 index 000000000..32c40d1b9 --- /dev/null +++ b/crates/syntax/fuzz/Cargo.toml | |||
@@ -0,0 +1,27 @@ | |||
1 | |||
2 | [package] | ||
3 | name = "syntax-fuzz" | ||
4 | version = "0.0.1" | ||
5 | authors = ["rust-analyzer developers"] | ||
6 | publish = false | ||
7 | edition = "2018" | ||
8 | |||
9 | [package.metadata] | ||
10 | cargo-fuzz = true | ||
11 | |||
12 | [dependencies] | ||
13 | syntax = { path = ".." } | ||
14 | text_edit = { path = "../../text_edit" } | ||
15 | libfuzzer-sys = { git = "https://github.com/rust-fuzz/libfuzzer-sys.git" } | ||
16 | |||
17 | # Prevent this from interfering with workspaces | ||
18 | [workspace] | ||
19 | members = ["."] | ||
20 | |||
21 | [[bin]] | ||
22 | name = "parser" | ||
23 | path = "fuzz_targets/parser.rs" | ||
24 | |||
25 | [[bin]] | ||
26 | name = "reparse" | ||
27 | path = "fuzz_targets/reparse.rs" | ||