diff options
author | Akshay <[email protected]> | 2021-10-27 12:40:42 +0100 |
---|---|---|
committer | Akshay <[email protected]> | 2021-10-27 12:43:23 +0100 |
commit | f909b20c540ea99dddfd04b8439ee35b8dd703b8 (patch) | |
tree | cc9a60108f975419bf2621262739071a5f0a1be6 /flake.nix | |
parent | ed1ee66b06add4c22e4922ffa762f097355c7431 (diff) |
allow stdin input to statix-single, vim pluginv0.2.2
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 11 |
1 files changed, 9 insertions, 2 deletions
@@ -49,7 +49,7 @@ | |||
49 | 49 | ||
50 | statix = with final; pkgs.stdenv.mkDerivation { | 50 | statix = with final; pkgs.stdenv.mkDerivation { |
51 | pname = "statix"; | 51 | pname = "statix"; |
52 | version = "v0.2.0"; | 52 | version = "v0.2.2"; |
53 | src = builtins.path { | 53 | src = builtins.path { |
54 | path = ./.; | 54 | path = ./.; |
55 | name = "statix"; | 55 | name = "statix"; |
@@ -75,10 +75,17 @@ | |||
75 | }; | 75 | }; |
76 | }; | 76 | }; |
77 | 77 | ||
78 | statix-vim = | ||
79 | with final; pkgs.vimUtils.buildVimPlugin { | ||
80 | pname = "statix-vim"; | ||
81 | version = "0.1.0"; | ||
82 | src = ./vim-plugin; | ||
83 | }; | ||
84 | |||
78 | }; | 85 | }; |
79 | 86 | ||
80 | packages = forAllSystems (system: { | 87 | packages = forAllSystems (system: { |
81 | inherit (nixpkgsFor."${system}") statix; | 88 | inherit (nixpkgsFor."${system}") statix statix-vim; |
82 | }); | 89 | }); |
83 | 90 | ||
84 | defaultPackage = | 91 | defaultPackage = |