diff options
author | Akshay <[email protected]> | 2021-10-24 08:54:52 +0100 |
---|---|---|
committer | Akshay <[email protected]> | 2021-10-24 08:54:52 +0100 |
commit | 5de0ba055cef7f2dc5451b1eaf0857deb77ae009 (patch) | |
tree | 2c9b0d9b6d90e071cbb9ebbbe2efcdf705e2375e /lib/Cargo.toml | |
parent | c79799c0e418c0c37e4076d653d64e6adaa3378b (diff) |
add support for json out
Diffstat (limited to 'lib/Cargo.toml')
-rw-r--r-- | lib/Cargo.toml | 10 |
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/Cargo.toml b/lib/Cargo.toml index e9e9e69..e9bca06 100644 --- a/lib/Cargo.toml +++ b/lib/Cargo.toml | |||
@@ -11,3 +11,13 @@ if_chain = "1.0" | |||
11 | macros = { path = "../macros" } | 11 | macros = { path = "../macros" } |
12 | lazy_static = "1.0" | 12 | lazy_static = "1.0" |
13 | rowan = "0.12.5" | 13 | rowan = "0.12.5" |
14 | serde_json = { version = "1.0.68", optional = true } | ||
15 | |||
16 | [dependencies.serde] | ||
17 | version = "1.0.130" | ||
18 | features = [ "derive" ] | ||
19 | optional = true | ||
20 | |||
21 | [features] | ||
22 | default = [] | ||
23 | json-out = [ "serde", "serde_json" ] | ||