aboutsummaryrefslogtreecommitdiff
path: root/macros/Cargo.toml
diff options
context:
space:
mode:
authorAkshay <[email protected]>2021-09-13 17:49:18 +0100
committerAkshay <[email protected]>2021-09-13 17:49:18 +0100
commit7a3c3822ba4a368b0475bc5de89ced78fa8b3cb5 (patch)
tree6c7c9d658958af3d5a7f9727202926421efd2e6a /macros/Cargo.toml
parent171a4fa4d15c4be14d63fdc5d258610bb26bd162 (diff)
add proc-macro to define lint
Diffstat (limited to 'macros/Cargo.toml')
-rw-r--r--macros/Cargo.toml9
1 files changed, 9 insertions, 0 deletions
diff --git a/macros/Cargo.toml b/macros/Cargo.toml
index 6a47e03..b2027fc 100644
--- a/macros/Cargo.toml
+++ b/macros/Cargo.toml
@@ -6,3 +6,12 @@ edition = "2018"
6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html 6# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
7 7
8[dependencies] 8[dependencies]
9quote = "1.0"
10proc-macro2 = "1.0.27"
11
12[dependencies.syn]
13version = "1.0"
14features = [ "full" ]
15
16[lib]
17proc-macro = true