aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix22
1 files changed, 11 insertions, 11 deletions
diff --git a/flake.nix b/flake.nix
index a319266..2c1db03 100644
--- a/flake.nix
+++ b/flake.nix
@@ -60,8 +60,10 @@
60 cargo 60 cargo
61 ]; 61 ];
62 buildPhase = '' 62 buildPhase = ''
63 cargo build -p statix --release --offline 63 cargo build -p statix --all-features --release --offline
64 ''; 64 '';
65 # statix does not have any tests currently
66 doCheck = false;
65 installPhase = '' 67 installPhase = ''
66 install -Dm775 ./target/release/statix $out/bin/statix 68 install -Dm775 ./target/release/statix $out/bin/statix
67 ''; 69 '';
@@ -85,19 +87,17 @@
85 devShell = forAllSystems (system: 87 devShell = forAllSystems (system:
86 let 88 let
87 pkgs = nixpkgsFor.${system}; 89 pkgs = nixpkgsFor.${system};
88 inherit (rustChannel pkgs) rust rust-src; 90 inherit (rustChannel pkgs) rust rust-src rust-analysis;
89 in 91 in
90 with pkgs; 92 with pkgs;
91 mkShell rec { 93 mkShell rec {
92 buildInputs = 94 buildInputs = [
93 [ 95 rustfmt
94 rust-analyzer 96 cargo
95 rustfmt 97 cargo-watch
96 cargo 98 rust
97 cargo-watch 99 rust-src
98 rust 100 ];
99 rust-src
100 ];
101 RUST_SRC_PATH = "${rust-src}/lib/rustlib/src/rust/library"; 101 RUST_SRC_PATH = "${rust-src}/lib/rustlib/src/rust/library";
102 RUST_LOG = "info"; 102 RUST_LOG = "info";
103 RUST_BACKTRACE = 1; 103 RUST_BACKTRACE = 1;