aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 90e5c56..f1cf699 100644
--- a/flake.nix
+++ b/flake.nix
@@ -8,7 +8,9 @@
8 flake = false; 8 flake = false;
9 }; 9 };
10 10
11 import-cargo.url = github:edolstra/import-cargo; 11 import-cargo.url = "github:edolstra/import-cargo";
12
13 gitignore.url = "github:hercules-ci/gitignore.nix";
12 14
13 }; 15 };
14 16
@@ -17,10 +19,12 @@
17 , nixpkgs 19 , nixpkgs
18 , mozillapkgs 20 , mozillapkgs
19 , import-cargo 21 , import-cargo
22 , gitignore
20 , ... 23 , ...
21 }: 24 }:
22 let 25 let
23 inherit (import-cargo.builders) importCargo; 26 inherit (import-cargo.builders) importCargo;
27 inherit (gitignore.lib) gitignoreSource;
24 28
25 supportedSystems = [ "x86_64-linux" "x86_64-darwin" "aarch64-darwin" ]; 29 supportedSystems = [ "x86_64-linux" "x86_64-darwin" "aarch64-darwin" ];
26 forAllSystems = nixpkgs.lib.genAttrs supportedSystems; 30 forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
@@ -49,9 +53,9 @@
49 53
50 statix = with final; pkgs.stdenv.mkDerivation { 54 statix = with final; pkgs.stdenv.mkDerivation {
51 pname = "statix"; 55 pname = "statix";
52 version = "v0.3.1"; 56 version = "v0.3.2";
53 src = builtins.path { 57 src = builtins.path {
54 path = ./.; 58 path = gitignoreSource ./.;
55 name = "statix"; 59 name = "statix";
56 }; 60 };
57 nativeBuildInputs = [ 61 nativeBuildInputs = [