aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index ba1c431..26190aa 100644
--- a/flake.nix
+++ b/flake.nix
@@ -49,7 +49,7 @@
49 49
50 statix = with final; pkgs.stdenv.mkDerivation { 50 statix = with final; pkgs.stdenv.mkDerivation {
51 pname = "statix"; 51 pname = "statix";
52 version = "v0.2.0"; 52 version = "v0.2.2";
53 src = builtins.path { 53 src = builtins.path {
54 path = ./.; 54 path = ./.;
55 name = "statix"; 55 name = "statix";
@@ -75,10 +75,17 @@
75 }; 75 };
76 }; 76 };
77 77
78 statix-vim =
79 with final; pkgs.vimUtils.buildVimPlugin {
80 pname = "statix-vim";
81 version = "0.1.0";
82 src = ./vim-plugin;
83 };
84
78 }; 85 };
79 86
80 packages = forAllSystems (system: { 87 packages = forAllSystems (system: {
81 inherit (nixpkgsFor."${system}") statix; 88 inherit (nixpkgsFor."${system}") statix statix-vim;
82 }); 89 });
83 90
84 defaultPackage = 91 defaultPackage =