diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 34 |
1 files changed, 20 insertions, 14 deletions
@@ -43,22 +43,28 @@ | |||
43 | { | 43 | { |
44 | 44 | ||
45 | overlay = final: prev: { | 45 | overlay = final: prev: { |
46 | statix = with final; (makeRustPlatform { | ||
47 | inherit (rustChannel final) cargo rustc; | ||
48 | }).buildRustPackage rec { | ||
49 | pname = "statix"; | ||
50 | version = (lib.importTOML ./bin/Cargo.toml).package.version; | ||
51 | 46 | ||
52 | src = gitignoreSource ./.; | 47 | statix = with final; |
53 | 48 | let | |
54 | cargoLock.lockFile = ./Cargo.lock; | 49 | pname = "statix"; |
55 | 50 | packageMeta = (lib.importTOML ./bin/Cargo.toml).package; | |
56 | meta = with lib; { | 51 | rustPlatform = makeRustPlatform { |
57 | description = "Lints and suggestions for the Nix programming language"; | 52 | inherit (rustChannel final) cargo rustc; |
58 | homepage = "https://git.peppe.rs/languages/statix/about"; | 53 | }; |
59 | license = licenses.mit; | 54 | in |
55 | rustPlatform.buildRustPackage { | ||
56 | inherit pname; | ||
57 | inherit (packageMeta) version; | ||
58 | |||
59 | src = gitignoreSource ./.; | ||
60 | cargoLock.lockFile = ./Cargo.lock; | ||
61 | |||
62 | meta = with lib; { | ||
63 | description = "Lints and suggestions for the Nix programming language"; | ||
64 | homepage = "https://git.peppe.rs/languages/statix/about"; | ||
65 | license = licenses.mit; | ||
66 | }; | ||
60 | }; | 67 | }; |
61 | }; | ||
62 | 68 | ||
63 | statix-vim = | 69 | statix-vim = |
64 | with final; vimUtils.buildVimPlugin { | 70 | with final; vimUtils.buildVimPlugin { |