diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 7 |
1 files changed, 4 insertions, 3 deletions
@@ -93,11 +93,12 @@ | |||
93 | "clippy" | 93 | "clippy" |
94 | "rust-src" | 94 | "rust-src" |
95 | ]; | 95 | ]; |
96 | inherit (fenix.packages."${system}") rust-analyzer; | ||
96 | in | 97 | in |
97 | with pkgs; | 98 | pkgs.mkShell { |
98 | mkShell rec { | ||
99 | nativeBuildInputs = [ | 99 | nativeBuildInputs = [ |
100 | cargo-watch | 100 | pkgs.cargo-watch |
101 | pkgs.cargo-insta | ||
101 | rust-analyzer | 102 | rust-analyzer |
102 | toolchain | 103 | toolchain |
103 | ]; | 104 | ]; |