diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 19 |
1 files changed, 19 insertions, 0 deletions
@@ -108,5 +108,24 @@ | |||
108 | RUST_BACKTRACE = 1; | 108 | RUST_BACKTRACE = 1; |
109 | }); | 109 | }); |
110 | 110 | ||
111 | |||
112 | apps = forAllSystems | ||
113 | (system: | ||
114 | let | ||
115 | pkgs = nixpkgsFor."${system}"; | ||
116 | cachix-push-script = pkgs.writeScriptBin "cachix-push" '' | ||
117 | ${pkgs.nixUnstable}/bin/nix build --json \ | ||
118 | | ${pkgs.jq}/bin/jq -r '.[].outputs | to_entries[].value' \ | ||
119 | | ${pkgs.cachix}/bin/cachix push statix | ||
120 | ''; | ||
121 | in | ||
122 | { | ||
123 | cachix-push = { | ||
124 | type = "app"; | ||
125 | program = "${cachix-push-script}/bin/cachix-push"; | ||
126 | }; | ||
127 | } | ||
128 | ); | ||
129 | |||
111 | }; | 130 | }; |
112 | } | 131 | } |